Live Migration schlägt nach VMM-Update fehl

Am Anfang war die Live Migration

Oder auch nicht:

Fehler (23008)
Die VM “xyz-Server” kann aufgrund von Inkompatibilitätsproblemen nicht zu Host “XYZ-Host” migriert werden. The Virtual Machine Management Service failed to establish a connection for a Virtual Machine migration with host ‘XYZ-Host’: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (0x8007274C).

Empfohlene Aktion
Beheben Sie das Inkompatibilitätsproblem, und wiederholen Sie den Migrationsvorgang.

Und nun?

So etwas kann einem echt den Abend verderben! So geschehen heute, nach der Wartung eines Hypervisors beim Versuch die VM wieder zu verteilen. Gücklicherweise findet man einige Hinweise, die bereits auf das jahr 2012 zurückdatieren. Dort wird im Zusammenhang mit NIC-Teaming von einer Race-Condition berichtet, die dafür sorgt, dass der VMM Client sich beendet.

https://blogs.technet.microsoft.com/roplatforms/2012/10/16/shared-nothing-migration-fails-0x8007274c/

Leider war das bei mir nicht mehr der Fall, es musste also etwas anderes sein – wobei der Port 6600 tatsächlich nicht abgehört wurde! Ein Neustart des Dienstes konnte ihn auch nicht zum Lauschen animieren.

Eine weitere Suche brachte das gleiche Problem im Blog von Rachfahl IT Solutions zu Tage:

Live Migration schlägt mit Event ID: 21502 fehl

Na, fast…

Das bestätigte zwar meine Erkenntnisse, aber noch immer war auf Port 6600 nix los. Als ich dann aber mit anderen Schlagworten suchte, wurde ich fündig:

VMM 2012 R2 Live Migration failure 0x8007274C

Robin, der Autor des Artikels, stellte fest, dass nach einem Upgrade von Server 2012 nach 2012R2 in einer VMM-Umgebung die Einträge für die Live Migration nicht mehr von VMM gesetzt wurden.

Die Einträge für die zur Live Migration genutzten IP-Adressen bzw. der Subnetze waren auch bei mir leer. Ich bin mir sehr sicher, dass dies vorher nicht der Fall war – ich bin mir auch sicher, dass ich auch vor Auftreten dieses Problems den VMM Agent aktualisiert habe…

Nach dem Eintragen der IP’s sieht das ganze mit netstat -a wieder rund aus, und die Live Migrationen laufen auch wieder:

vmm_port6600_listening

Dann kann ich ja mal über den Feierabend nachdenken!

Schreibe einen Kommentar